Difference between revisions of "Incompatible DirectX"

Difference between revisions of "Incompatible DirectX"

From BeamNG
Line 3: Line 3:
 
For more info, you can check the system requirements here: '''[[Requirements | System Requirements]]''' and also our '''[https://blog.beamng.com/deprecation-of-directx10-support DirectX 10 blog post]'''.
 
For more info, you can check the system requirements here: '''[[Requirements | System Requirements]]''' and also our '''[https://blog.beamng.com/deprecation-of-directx10-support DirectX 10 blog post]'''.
  
There various possible solutions you can try:
+
There's various possible solutions you can try:
  
 
#Switch to one of the unmaintained DirectX9 or DirectX10 branches that we are specifically providing for these outdated graphic cards
 
#Switch to one of the unmaintained DirectX9 or DirectX10 branches that we are specifically providing for these outdated graphic cards

Revision as of 14:22, 1 March 2019

If BeamNG.drive directed you here, this means your computer doesn't meet the minimum requirements to be run properly. Specifically, your Graphics Card is not compatible, as it doesn't support DirectX version 11.

For more info, you can check the system requirements here: System Requirements and also our DirectX 10 blog post.

There's various possible solutions you can try:

  1. Switch to one of the unmaintained DirectX9 or DirectX10 branches that we are specifically providing for these outdated graphic cards
  2. Upgrade your graphics card so it meets the minimum requirements
  3. If you recently bought BeamNG.drive, contact the store you bought it from, as you might be able to get a refund from them (Steam, Humble Bundle, etc)


  • NOTE. Sometimes this issue can occur on compatible hardware, due to bad video drivers not reporting the correct supported DirectX version of the hardware. Reinstalling the video drivers may help in these cases.

If you are unsure which DirectX versions are supported by your video card, check following the steps:

Extracting the techdemo folder from the ZIP


Reverting to an older version of the game

Note that these version will not receive updates!

1. Right Click 'BeamNG.drive' in your Steam Library

2. Select 'Properties', and go to the 'Beta' tab

3. Select the appropriate version for your hardware (see below)

Betas-dx9 1.png


  • 0.4.0.6-dx9 - Last version to support DirectX9 Graphics Cards
  • 0.14.0.5-dx10 - Last version to support DirectX10 Graphics Cards

Refund / Support

Sorry for the inconvenience! Below are described the steps to request a refund from Steam or Humble Bundle, as well the stores requirements to be eligible for one.

Sorry to see you go! :(

Steam

You can request a refund here: https://support.steampowered.com/kb_article.php?ref=6695-QIKM-7966

  • NOTE. Refunds for Steam purchases are managed exclusively by Steam itself. Please carefully check the limits within a refund is applicable.

Humble Bundle

1. Purchase must not be older than 30 days

You can request a refund by contacting us: https://support.beamng.com/

Please specify the email address used in the original order, in case you contact us using a different one.